デル・テクノロジーズ製品 販売支援サイト
情報ガイドステーションメニュー
 |  PowerStore検証記 -第3回【PowerStore – PowerEdge接続回】-
      ~関西若手SEで話題のPowerStoreを触ってみた!~






名前:増子 達也
CTC歴 :2年目
主な業務内容:
サーバーインフラSE
名前:竹田 明浩
CTC歴 :1年目
主な業務内容:
サーバーインフラSE
お久しぶりです!伊藤忠テクノソリューションズ株式会社(CTC)で、入社1、2年目のサーバインフラSEをやっております竹田/増子と申します!

PowerStore検証記も3回目を迎えましたが、改めて、拙い文章に興味を持って、閲覧いただき本当に有難うございます。少しでも、共感いただけたり、構築・検証の際の気づきにつながっていたら幸いです。



前回のおさらいですが、デル・テクノロジーズ株式会社(以下、デル・テクノロジーズ)様にサポートいただきながら、機器の搬入、PowerStoreの簡単な概要に関するお勉強、そして、実機を触りながら、初期セットアップまで完了させました。



では、ここから検証を行っていきましょう!!
・・・と言いたいところなのですがその前に、第1回でご説明したAnsibleを活用したボリュームの自動作成やデータの削減効果の確認やNASの検証を行うために、PowerStoreをブロックストレージとして活用した仮想環境を作っておきたいと考えました。
ということで、第3回の目標は、「PowerStoreで作成したボリュームをホストサーバで認識させること」です。

まずは検証用の仮想環境が必要になりますが、自由に触れるサーバが手元になく、サーバはどうしようかな?検証用に購入するのも、中々難しいし。。。
と、悩んでいたところ、デル・テクノロジーズ様から「より深い検証を行って欲しいので特別に…」ということで、PowerEdgePowerStoreをセットでお借りすることができました。(本当に有難うございます!)


※お貸しいただいた、PowerEdge
PowerEdgeに関する情報はこちら


さっそく物理機器の手配を進めながら、検証環境構築に向けて全体概要の整理を行う為に、構成図の作成、IPアドレス・VLAN設定の検討を行います。



上記の構成図を元に、「PowerStoreで作成したボリュームをホストサーバ(PowerEdge)で認識させる」という目標を達成する為の今回の大まかな流れを以下としました。

今回の大まかな流れ

1.PowerEdge(ホストサーバ)のキッティング
2.S4112F(SAN-SW)のNW設定
3.物理結線
4.iSCSI設定

※検証では、仮想化基盤の環境構築に対する理解に加え、検証準備を含めて若手SE2人で完遂させることを目標としました。(結果的に、本当に手詰りになった時にご相談させていただいた場面もありましたが。。。)
結論からお伝えすると、PowerStoreの設定はGUIにより非常に簡単に行えることが判りましたが、それ以前にいくつかの単純なポイントで行き詰まり、事前の想定より時間が掛かってしまいました。(私達若手2人だけの拙い知識で対応を完遂させようとしたことが理由と認識しています。)
私達と同じような若手SEへの参考として、今回の検証記では私達が実際に行き詰まってしまったポイントも記載させていただきます!







1.PowerEdge(ホストサーバ)のキッティング

まずは、「PowerEdge R630」の初期設定と、OSとしてESXiのインストールを実施します。

〇初期設定について

PowerEdgeの初期設定では、iDRACに対してIPアドレスを付与する作業を行います。
iDRACとはリモートでサーバに関する設定や操作を可能にする機能で、OSから独立しているものになります。
機器が工場から出荷された時点では後述する初期IPが割り当てられていますが、変更は必須だと思いますので、その設定方法を説明します。
参考までにR630のiDRACポートの位置は、以下の画像の赤い四角の部分になります。



詳しい機能については本情報ガイドステーションの下記サイトにございますので、是非ご確認ください。
iDRACとは?

ここからは実際の設定に取り掛かります。
※今回はiDRAC8の設定方法になりますが、iDRAC9や他のバージョンでも同様の設定方法になります。
iDRAC9の設定方法はこちらから

まずはPowerEdgeに繋ぐPCのIPを設定します。
iDRACは出荷時に192.168.0.120/24のIPが割り当てられていますので、こちらと同じネットワークでかつ、.120を除いたIPで割り当ててください。

IPの設定が完了しましたら、iDRACのポートとPCを繋ぎ、サーバ前面の電源ボタンを押して電源を投入します。
ブラウザで「https:// 192.168.0.120」で検索すると以下のログイン画面が出てきますので、デフォルト設定の下記IDとパスワードを入力してください。
ID:root
Passworld:XXXXXX
※初期パスワードは下記のサイトに記載されていますので、ご確認ください
初期パスワードの確認はこちら


画像はクリックで拡大できます


次にデフォルトのパスワード変更を行うかを確認する画面が出ますので、変更する場合は新しいパスワードを入力し、「続行」を選択します。


画像はクリックで拡大できます


ログインに成功すると以下の画面になります。


画像はクリックで拡大できます


次にiDRACの初期IPの変更を行います。
左ペイン「iDRAC設定」>「プロパティ」>「設定」の順に選択します。


画像はクリックで拡大できます


「現在のIPv4設定」を確認し、設定したいIPやDNSに関する設定を行った後、一番下までスクロールし「適用」を選択し、設定内容を反映します。
※この時点でiDRACのIPが変わりますので、PCに設定されているIPを変更後のネットワークに繋がるように設定を変更してください。

ブラウザの別タブで「https://変更後のIP」を検索し、再度ログインに成功したらIPの変更作業は完了です。

〇ESXiのインストールについて

続いてOSであるESXiのインスト-ルを行います。
事前準備として、ESXiのISOイメージをご用意ください。VMwareの公式サイトで最新バージョンのISOイメージをダウンロードすることができます。

それではESXiのインストールを開始します。
まずはブラウザから「https://iDRACのIP」で検索し、初期セットアップ時に設定した管理者ユーザでログインします。

次に、左ペイン「概要」>「サーバー」>画面上「プロパティ」>仮想コンソールから「起動」を選択します。


画像はクリックで拡大できます


すると下記のようなウィンドウが出てきますので、「仮想メディアの接続」を選択します。


画像はクリックで拡大できます


さらにウィンドウがでますので、CD/DVDをマップのイメージファイル「ファイルを選択」を選択し、事前に準備したESXiのISOイメージを選択します。


画像はクリックで拡大できます


選択が完了すると、ISOイメージ名が表示されますので確認後、「デバイスマップ」を選択します。


画像はクリックで拡大できます


デバイスのマップが完了すると、「ISOイメージ名 はCD/DVDドライブにマッピングされています。」と表示されますので、確認後ウィンドウ右上の「×」マークを選択してウィンドウを閉じます。

iDRACの画面に戻り、左ペイン「概要」>「サーバー」>画面上「プロパティ」>クイック起動コンソールから「電源を入れなおす(コールドブート)」を選択します。


画像はクリックで拡大できます


画面上に「サーバー制御処理を実行しようとしています。続行してもよろしいですか?」というポップアップが出てきますので、「OK」を選択します。

仮想コンソールビューが「No Signal」になり、下記の表示が出ればインストールは無事に進んでいます。


画像はクリックで拡大できます


ここから先はESXiの初期セットアップ方法やIP等の設定になりますが、本検証記では割愛します。
セットアップ方法は下記サイトが参考になりますのでご興味のある方はご覧ください。
VMware vSphere ESXi 6.xインストール手順はこちら

サーバの初期設定や、OSのインストールは以前実施した経験があったためスムーズに進めることができ、無事ESXiのインストールし、PowerEdgeキッティングが完了しました。


画像はクリックで拡大できます








2.S4112F(SAN-SW)のNW設定

次に、「S4112F(SAN-SW)のNW設定」に取り掛かります。
PowerEdgeをPowerStoreと通信させるために、S4112F(SAN-SW)の設定が必要となります。


S4112F
DELL Sシリーズに関する情報はこちら


初期セットアップを行う際に、SWの電源は入れていたので、「物は試しだ!!」ということでさっそく設定取り掛かったのですが、初めから躓いてしまいました。。。
実際に設定を行っていく中での、初めの壁は、、、

コンソールポートってどれ?
初期PWって何?
設定方法が分からん。。。

でした。
※そんなことも知らんのかよ!!となった皆様。まったくもってその通りなのですが、今回はそのお気持ちをぐっとこらえて、そういう時期もあるよね!と寛大な心で見ていただけると幸いです。

今回の構成に必要な設定は「VLANの設定」と「接続を行うインターフェースの設定」ですが、SWの設定は日常業務の範疇外で基本的な知識を持っていませんでした。今回行う必要のある設定はそこまで困難なものではないと思うのですが、まずは「S4112F」、「Sシリーズ」、「DELL SW」についての情報収集から始めました。

〇コンソールポートについて

コンソールポートの位置を含め、ハードウェアに関する情報はデル・テクノロジーズ様のサポートサイトで簡単に見つけることができました。


S4112F インストールガイド



〇初期PWについて

初期PWについては、別シリーズ(Xシリーズ)の初期セットアップの記載の中に、「初期Username:admin、Password:XXXXXX」との記載があったので、実機で試した所、ログインすることができました!
パスワードは上記Xシリーズのセットアップ記事をご確認ください。

〇設定方法

初期PWと同様になかなか見つからなかったのが、「コマンド」でした。
インターネットで検索すると、同じSシリーズでもインターフェースの設定が「TenGigabitEthernet」と表記されていたりと、惑わされることもあったのですが、デル・テクノロジーズ様に準備いただいている「VLTの設定方法」の中から、管理者モードに入るのは、「configure terminal」であるということと、合わせてインターフェースの指定方法が分かりました。その他、VLANの作成方法スイッチのモード変更ポートに対するVLANの割り当てなどが作業当初は分かりませんでしたが、今回構築を行った、S4112Fでは、「Tabキーによるコマンド補完と候補の表示」を行う機能があったので、どんな設定があるのかを見ながら、設定を行いました。

〇設定内容

#VLAN 150の作成(interface vlan ~(作成するVLANの数字))
interface vlan 150
no shutdown !

#VLAN 200の作成
interface vlan 200
no shutdown
!

#管理者モード(configure terminal)に入り、interface ethernet(range指定可能)1/1/x(rangeの場合(1/1/1-1/1/12)))
interface ethernet (1/1/1)
no shutdown
switchport mode trunk
switchport trunk allowed vlan 150,200
flowcontrol receive on
!

※後日、この記事を記載しているタイミングで本当に参照できる情報はなかったかなと再度検索した所、サンプルコードなるものを準備いただいているのを発見致しました。(もっとしっかり調べればよかったです。。。)






3.物理結線

S4112F(SAN-SW)のNW設定」も完了したので、「物理結線」に進みます!

PowerStoreの接続は、4ポートカードに搭載されているSFPポートとS4112FのSFPポート光ケーブルでつなぎ、その後、PowerEdgeも同様に、拡張カードスロットに搭載されていたSFPポートとS4112FのSFPポートを光ケーブルでつなぎました。


PowerStore 4ポートカード(実物はSFPでした。)
PowerStore背面図



S4112F SFPポート
S4112F背面図



PowerEdge PCIe 拡張カードスロット(ライザー2)(実物はSFPでした。)
PowerEdge背面図


接続先が分かった後は、光ケーブルを汚さない様に慎重に結線するだけですので、問題なく完了しました。


実際の結線後の背面(非常に分かりにくいですが、赤枠で囲っている箇所を結線しています
画像はクリックで拡大できます




結線後PowerStoreのGUI上でもLink UPしていることが確認できました。
画像はクリックで拡大できます









4.iSCSI設定

続いて、iSCSIの設定を行っていきます。
iSCSIの設定には、事前準備として「ESXiのNW設定」と「PowerStoreのNW設定」が必要となります。

初めに、「ESXiのNW設定」です。
SW2台に対して光ケーブルを接続しているので、PowerEdge側のNW設定も2つ準備しました。
ESXiのNW設定は初めてで設定箇所を把握できていませんでしたが、どの設定が必要か理解できた後では、特に行き詰まった箇所はありませんでした。

〇設定画面



次にPowerStoreのNW設定です。
※PowerStoreに関する設定については、基本的にキャプチャを交えながら、設定方法を記載します。

ギアアイコンの「Settings」から「Networking」の「Network IPs」で「+CREATE」を選択します。



必要情報を入力して、「NEXT」を押します。



Link UPしている、portを選択して「FINISH」を選択することで、PowerStoreのNW設定は完了しました。


画像はクリックで拡大できます


個人的な感想ですが、準備されているGUIは、設定の順番や操作のしやすさの面でとても使いやすいな、と感じました。
こちらの設定についても特に何か困ることはありませんでした。

これで、事前準備は完了なので、iSCSIの設定を行っていきます!
PowerStore 側のiSCSIの設定は、ホストサーバの登録設定の中で行います。
「Compute」のプルダウンから「Hosts&Hosts Groups」から「ADD HOST」を選択します。



「Host Details」では、「ホスト名の入力」、「OSの選択」を行い「NEXT」を選択します。



「Initiator Type」では、接続するプロトコルを選択し、「NEXT」を選択します。



「Host Initiators」では、ESXiの「ストレージ」>「アダプタ」>「ソフトウェアiSCSI」から確認し、「iqn~」を入力し、「ADD」を選択します。



設定したイニシエータ情報が登録されていることを確認し、「NEXT」を選択します。



「Summary」で設定した情報に間違いが無いか、確認し、「ADD HOST」で設定が完了します。



合わせて、ESXiで認識させる為のボリュームの作成も行っていきます。
まず、「Storage」の「Volumes」を選択します。



「+CREATE」を選択し、ボリューム名、容量を選択し、「NEXT」を選択します。



接続プロトコルを選択し、先程作成した、ホストサーバを選択、その後「NEXT」を選択します。



「Summary」で設定した内容に間違いがないか確認し、「CREATE」でボリュームの作成が完了します。



これで、PowerStore側でのボリューム作成も完了です。
※今回は、「PowerStore_test1」で作成しました。



続いて、ESXi側のイニシエータの設定を行っていこうと考えたのですが、2点問題が発生しました。
それは、

PowerStoreのiqnが記載されている箇所が分からない
iSCSI用に設定したポートが疎通できていない

です。


〇iqnの記載について

ESXiの「ストレージ」>「アダプタ」>「ソフトウェアiSCSI」からiSCSIの設定を行っていこうと考えました。



先程作成した、「iSCSIA」、「iSCSIB」をポートバインドに設定し、固定ターゲットを指定しようとしたのですが、PowerStore側のGUIから、iqnの設定が記載されている箇所が見つかりませんでした。
(調べた所、同じDellストレージであるUnityでは、設定画面から参照することができていたようです。)

未だに、PowerStoreのiqn設定を確認する方法は把握できておらず、今回は、「動的ターゲットの追加」で認識させました。
(後述する、iSCSI用のポートの疎通不可によりこの段階では、この動的ターゲットの追加もできませんでしたが。)


〇iSCSI用ポートの疎通ができていない

iqnの設定もわからず、iSCSIの設定が完了しない状態で悩んでおり、検証期間も限られていたので、解決に向けて社内各所で相談していた中で、PowerStoreのGUI画面を見ていただいたある先輩社員から以下のご指摘をいただきました。

そもそも、設定したポートが疎通できていない様に見えるよ。。。

エラー画面を確認した所、設定したIPでICMPが疎通できていないエラーが発生していました。(iqnを見つけられれば、設定ができてると考えていましたが、根本的にNWの疎通ができていませんでした。)
※あくまで筆者の確認が不足していただけで、下記アラートは「Monitoring」-「Alearts」に非常に分かりやすく表示されていました。。。



原因は分かったものの、PowerStoreのネットワーク設定を間違えたかなと考えて設定を見直しましたが特段変な箇所も見つかりません。とりあえず疎通確認をしてみようと思いPowerStoreにログインし、pingを飛ばそうとしますが、今度はインターフェースを指定したpingの飛ばし方が分からず、またここで手詰りになってしまいました。。。

再度情報収集に戻り、「ping -i」コマンドでインターフェースを指定して、pingを飛ばせること、インターフェース名は、「ip」コマンドで表示されることが分かり、pingを飛ばしてみた所、ノードA,B間(192.168.0.200-192.168.0.201)で疎通ができていないことが確認できました。

さらに追加で先輩社員から、以下のご指摘を受けました。

先輩社員:「両方(PowerEdge,PowerStore)とも、VLAN200に設定しているけど、もちろんポートのモード設定は、trunkに設定してるよね?
竹田   :「通している、VLANは一つなので、accessにしています。
先輩社員:「・・・・そこだね。。。

結果、私の勉強不足で、SWの設定が間違っていました。
(疎通させるVLANが一つの場合、TAG-VLANでもaccessで設定するものと勘違いしていました。。。)

〇元々のSW ポート設定
interface ethernet1/1/x
~
switchport access vlan 200
~

〇最終のSW ポート設定(上述の2.S4112Fの設定ではこちらを記載しています。)
interface ethernet1/1/x
~
switchport mode trunk
switchport trunk allowed vlan 150,200
~

この設定を変更させていただいた所、ノード間の通信はもちろん、PowerEdgeのiSCSIへのポート(192.168.0.100-101)への疎通も通る様になりました。

その後、先程のESXi上、「ストレージ」>「アダプタ」>「ソフトウェアiSCSI」からiSCSIの設定で、「動的ターゲットの追加」を行い、「設定の保存」を行った所、保存が完了しました。
最後に「再スキャン」を行い「新しいデータストア」から、「新しいVMFSの作成」を選択、先程作成した、ボリューム「PowerStore_test1」が見えるようになったので選択し設定を完了した所、無事ESXi上にボリュームを認識させることができました。



これで第3回の目標であった「PowerStoreで作成したボリュームをホストサーバで認識させること」が完了しました。

合わせて、先程認識させたボリュームを使ってESXi上にvCenterの構築を行いましたが、ISO ファイルをダウンロードし、ウィザードに沿って進めるだけだったので、特段問題なく構築することができました。


画像はクリックで拡大できます




今回の「PowerStore–PowerEdge接続」にむけて検証環境の構築を行ってみた所感

〇PowerStoreの設定に関して

今回で行った、PowerStoreの設定については、以下の通りです。

・NW設定
・ホストサーバの登録(iSCSI設定含む)
・ボリュームの追加

設定はすべてGUI上で行うことが可能で、GUIによる設定は非常に分かりやすく、また画面の操作性も良いと感じました。今回は、SWの設定ミスがあったので、切り分け時にPowerStoreの設定間違いの疑いも考えましたが、周辺機器(ホストサーバ、NW機器)の設定がうまくいっていて、且つ結線も間違っていなければ、PowerStoreの設定が分からないから構築が進まないとなることは考えにくいのかなと感じました。(それぐらい設定はシンプルでした。)
合わせて、NWの設定に問題がある場合でも、アラート画面には障害切り分けに必要な情報が表示されるので、対応策も立てやすいかと思います。(今回のケースは完全に私の確認、知識不足でした。)

今回も、掲げた目標をどうにか達成することができたので、今回はこの辺で!

本検証記は全4回を予定しております。
次回はいよいよ最終回の「第4回【検証実践編、検証記まとめ】」です!
検証内容の発表と、今回の検証記のまとめをいたしますので、是非ご覧ください!

今回から読み始めた、あるいは最終回を前にもう一度いままでの奮闘を振り返りたい!という方は、是非下記リンクから過去の記事をお読みください。

■第1回【DXインフラWG×PowerStore概要】
弊社のDXに対する取り組み内容とPowerStoreの概要について説明します。

■第2回【PowerStore初期セットアップ編】
初期セットアップの流れや注意点を説明します。

【CTCお問い合わせ先】
DXについて検討は行っているものの、何から取り組めばいいか分からない、取り組んでいるもののできているか分からないなどありましたら、お気軽にお問い合わせください。
DXインフラWGのお問い合わせ先は下記になりますので、ご連絡をお待ちしております。
dxinfra-wg@ctc-g.co.jp


2021/12/13


 

タグ: , ,